Workload misconfigurations

RDS database instance is using an unsupported engine version

Risk Level

Informational (4)

Platform(s)

Description

RDS database instance ""{AwsRdsDbInstance}"" is using an unsupported engine version. The database engine is ""{AwsRdsDbInstance.Engine}"" and the current version being used is ""{AwsRdsDbInstance.EngineVersion}"". When an engine version is no longer supported it does not receive important security fixes and may leave your data exposed to security risks. In addition, instances using unsupported engine versions may be upgraded automatically by AWS. This upgrade can occur outside the maintenance window which can cause errors in functionality
  • Recommended Mitigation

    We recommend to upgrade the engine version of the instance to the latest version available. If you do not wish to upgrade, you may downgrade to a previous supported version, if available